Announcement Announcement Module
Collapse
No announcement yet.
Whiteline rear sway bar Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Whiteline rear sway bar

    Has anyone installed Whitelines rear sway bar?

    I know a lot of previous threads talked about it but i haven't seen any updates listing results or opinions

    http://www.whiteline.com.au/product_...t_number=BMR91

    Any Comments?

  • #2
    Yep, I got one. V happy with it. Haven't scrapped anything and no noises from it.

    http://www.rcolt.com/showthread.php?...o-SA.../page13

    Comment


    • #3
      Thanks,

      Unlike most others i seem to be experiencing a lot of traction loss on exit of corners and have been told that the rear sway bar will help bring the back around. Im thinking of combining this with a front caster kit to really punch me out of corners.

      Comment


      • #4
        Check out the Whiteline website or Autospeed.com for how/why a sway bar works.
        Rear SB will reduce understeer on FWD car. Tyre pressures will help also - I run 40psi front and 37psi rear.

        Comment


        • #5
          Originally posted by odysseyesm View Post
          Check out the Whiteline website or Autospeed.com for how/why a sway bar works.
          Rear SB will reduce understeer on FWD car. Tyre pressures will help also - I run 40psi front and 37psi rear.
          I run 41psi front and back with AD07s. A bit noisy but haven't had any other issues.

          Comment


          • #6
            this thing is driving me fucking nuts atm. banging and knocking. the stupidfucking U braces slide around too.

            raging. i want a cusco
            Last edited by 0dd0ne; 24-09-2012, 10:51 AM.

            Comment


            • #7
              Originally posted by 0dd0ne View Post
              this thing is driving me fucking nuts atm. banging and knocking. the stupidfucking U braces slide around too.

              raging. i want a cusco
              Do the bolts up tighter, Buy some 2nd bolts as well to lock in the first ones then they wont move.

              Slide the brackets into a position that makes the bar clear the torsion bar, and make sure its not your exhaust knocking

              Comment


              • #8
                Second what macca said. I just installed mine and used impact wrench (which I just bought.. so very happy I finally got a powerful one). It seems to get them very very tigh and I have had no noise. Did you put a lot of grease on the bushes?

                Comment


                • #9
                  I think the U bolts should not move at all. Mine are rock solid

                  Comment


                  • #10
                    Lots of grease. There's no thread left on the u clamps. I think they are banging on the fuel tank. Such a shit design.

                    Comment


                    • #11
                      wow really... can you take a photo of your installed bar to show how its installed?

                      I think it shouldnt be tightened all the way untill there is no thread. I noticed the steel plate reinforcement bending a little as it got really tight (approx 1cm of thread left). Maybe something is put the wrong way around?

                      Comment


                      • #12
                        I dont think it can go on the wrong way. Im going to fuck with it tonight. Try move the u clamps away from the tank

                        Comment


                        • #13
                          Originally posted by 0dd0ne View Post
                          I dont think it can go on the wrong way. Im going to fuck with it tonight. Try move the u clamps away from the tank
                          Use ur new bar to tighten it

                          Comment


                          • #14
                            it might actually not be my sway but i cant see anything else that would be making the noise. it only happens when going over bumps and its from the rear axle.

                            Comment


                            • #15
                              Dont you have a rpw v1 exhaust?

                              Bumping on the fuel tank?

                              Comment

                              Working...
                              X